
SmartCarve4.3 Installation

You will use SmartCarve software installed on your desktop/laptop to use your laser machine, this software can be

found in the DVD that came with your machine.

1. Insert the USB dongle and install disc into your computer.

2. Open the install disc and select “English”.

3. Select “Engraving/Cutting”.

4. Select “CMA Series”.

5. Under “Applicable Models” select “CMA1390”.

6. Scroll down to “Mainboard No.5” and select the “Download” button next to “PC Software SmartCarve4.3”.

7. Follow the install process, when prompted select “Controller No.5” to match your machine.

FRONT DISPLAY INTERFACE



Using SmartCarve Software
SmartCarve4.3 is the control software that communicates with and controls the laser system. The following files

are compatible with SmartCarve:

For vector file, .ai, .cut, .dat, .dsb, .dst, .dxf, .emd, .hpg, .hpgl, .nc, .oud, .oux, .out, .plt, .smc, .sto, .txt, .yln, .ymd,

and .saw.

For Raster files, .bmp, .gif, .jpg, .jpe, and .jpeg.

Opening SmartCarve

A typical job starts with the creation of a design in SmartCarve or importing a bitmap or vector file into the SmartCarve software.
Once you are satisfied with your design, follow these steps:

1. Open SmartCarve. Double-Click the SmartCarve shortcut on your computer’s desktop.

2. Create File or Import File. There are several different design tools that can assist with creating vector lines within
SmartCarve. If a design is already created select “File” in SmartCarve and then select “Import File”. That will open up a
search window for you to locate the desired file needing to be worked with.

3. Options. You can now ensure that the cutting head is in proper focus to your material and your file parameters are at
your desired settings before outputting the job onto the material.

SmartCarve Interface
In this section you will be introduced to the major interface features of SmartCarve.



WORK SPACE

The workspace window shows a preview of your current job.

Top Toolbar

FILE - The File menu allows the user to open, import, export and save files within Ezcad.

New- open new file

Open- open existing file

Close- close existing file

Save- save the current file

Save As- save the current file as any of the file options chosen

Import File- bring in (or import) a file save on your computer

Import File to Lib- import a file save on your computer directly to the software library

Export File- take out (or export) a file from the software into your computer

Recent File- open a recently visited file here

Exit- close window



EDIT- The edit menu allows you to edit an existing project within the SmartCarve software.

Undo- remove previous action

Redo- brings back the removed action

Delete- deletes selected object

Copy- copies selected object

Cut- removes selected object

Paste- places copied object in workarea

Cut Out- removes a part of the object

Two-position rotating- rotates the selected object

Clone- make an immediate copy

Add to graph lib- add selected object to the graph library

Nest- the process of placing one element inside another

Nest here- element will be placed here

Prev Graph- displays previous graph

Next Graph- displays the following graph

Curve Edit- edit the curve

DRAW- The Draw menu allows you to create a series of points, shapes, and other characters in a project.

Pick/Select- select an object

Edit Node- edit a placed node

Line- draw a line

Rectangle- draw a rectangle

Regular_Polygon- draw a polygon

Ellipse- draw an ellipse

Bezier1- draw a bezier graph

Bezier2- draw a bezier graph

Text- add a text box

Drill- use the drill option

Bitmap File- add a bitmap file

Vector File- add a vector file

MODIFY- The Modify menu allows you to change specific object properties.

Mirror- Mirror the selected image

Fill- Fill the selected vector

Coordinate- move an image to selected coordinates

Convert Line- convert to a line

Convert Dashed- convert to a dashed line

Optimize Path- optimizes the path for travel time and smoothness’

Shrink and Expand- scale your image here

Add Lead-

Link Line- connect lines together

Close Curve- close the curved graph

Welding Line- create a line for welding

Drill to small circle- use the drilling option to create a small hole

Small graph to drill- use a graph for drilling



Group- group items together

Scatter Group- disperse the selected group

Convert Array- convert the selected object into an array

Scatter Array- disperse the selected array

Detach Leftover- remove any extra elements

Find Overlap Line- locate overlapping lines

VIEW- The View menu allows you to specific tools within the software or hide tools you do not want to use.

Grid- produce a grid

Ruler- produce a ruler

Switch

Graph List

Tree List

Graph Library

Control Bar

Toolbar

Standard View

Snap Graph

TOOLS- The Tools menu allows the user to make changes to the machine and software.

Language - select the software language

Machine Switching

Unit

Machine Setting- enter the machine’s settings

Config.- enter the machine’s configurations

WINDOWS- The Windows menu allows you to open multiple workspaces and adjust their placement.

New Window

Cascade

Tile Horizontally

Tile Vertically

HELP- The Help menu allows you to refer to your software version.

Help

Help/Controller

About



System Bar (Part 1)

NEW DOCUMENT- This button allows you to open a new document if needed. If the current document is not saved

when this button is pressed the software will prompt you to save your work before opening a new document.

OPEN PROJECT- This button allows the user to open a document previously saved. If the current document is not

saved when this button is selected then the software will prompt you to save your work before opening a new

project.

SAVE PROJECT- This button allows you to save your current job as an .ezd or Ezcad file. Once saved that file can be

opened again using the “Open Project” button.

CUT- Once an item within your design is selected this button allows you to cut the item out of the project and paste

it if desired in another location.

COPY- Once an item within your design is selected this button allows you to copy that item to be pasted in another

location of your project if desired.

PASTE- This button allows you to have an item cut or copied and then paste it to a desired location within your

project.

CUT OUT- This button allows you to clip a section of a vector file out.

UNDO- This button allows you to undo an action that was done while working on your project.



REDO- This button allows you to redo an action that was undone while working on your project.

TREE LIST- This button allows opens a tree which displays layers and polylines in a vector file.

CONFIG- This button allows opens a dialogue where the user can change software parameters.

ZOOM WINDOW- This button allows you to zoom in with a left click and zoom out with a right click.

ZOOM PAN- This button allows you to click and drag to scroll across the workspace.

ZOOM IN- Clicking this button will zoom in.

ZOOM OUT- Clicking this button will zoom out.

ZOOM ALL- This button will zoom to fit all graphics in the workspace.

ZOOM AREA- This button will zoom into a small area of approximately 1 mm.

VIEW WORKSPACE- This button will zoom to fit the entire workspace.

GROUP- This groups multiple vectors together as one vector.



System Toolbar(Part 2)

SCATTER GROUP- This ungroups a vector that was previously grouped.

CONVERT ARRAY- This button will create an array of the selected graphic.

SCATTER ARRAY- This button converts an array into individual graphics rather than one large graphic.

FILL- This button will fill a vector graphic for engraving.

SHRINK AND EXPAND- This button creates an outline/inline of a vector graphic.

ADD LEAD- This button adds a lead in/out to a selected vector graphic.

CLOSE CURVE- This button will automatically draw a line across the two endpoints of an open vector graphic.

LINK LINE- This button is used to link a curve that has a similar node to a new curve.

WELD LINE- This button will delete overlapping portions of two vector graphics and join them together.



MACHINE SETTING- This button will allow you to change machine parameters saved onto the laser controller.

SIMULATION TOOLPATH- This button will open window where the toolpath of the current workspace is shown.

NEST- This button will.

DRAWING TOOLBAR

Select- Select objects using this tool. You can use your mouse to select objects within the workspace.

Edit Node- When an object is selected using this function there will be nodes that appear around the object. These
nodes are illustrated as hollow squares, the largest being the start point. Click and drag on a node to move it.

Line- This tool allows you to draw a line or create an object out of line segments. Select this icon and then click on the
work area, the first line segment will appear. By selecting another point the line will continue, right click to stop.

Rectangle- This tool allows you to create a square or rectangle.

Regular Polygon- Draw a regular polygon, on the left sidebar the number of angles and size can be defined.

Ellipse- Draw an ellipse by selecting the work area and dragging to the cursor until you reach the dimensions. When
selecting the ellipse a toolbar will appear on the left allowing you to input a specific radius.

Bezier- Draw a Bezier curve. You can add as many curve points as desired.

Bezier2- Draw a revised Bezier curve. You can add as many curve points as desired.

Text- Create text within the workspace. When you select the text within the work area a toolbar will appear on the left
side allowing you to edit the text font type, font size, etc.

Drill- Place a point on the workspace for the laser to fire ove and the time in milliseconds.

Bitmap File- This tool allows you to import a bitmap file into the workspace

Vector File- This tool allows you to import a vector file into the workspace.



Object List

The Object List shows all the layers present in the workspace as well as the individual polylines of those

layers. Below that is listed the position and size of the selected graphic. This can be locked in order to maintain the

aspect ratio, or to lock it from any future changes.

Alignment Bar

Move to Origin- Align the selected graphic to the origin of the workspace.

Align Left- Align the selected graphics left edges together.

Align Right- Align the selected graphics right edges together.

Align Top- Align the selected graphics top edges together.

Align Bottom- Align the selected graphics bottom edges together.

Align Center- Align the graph in the center



Same Width- This button will make the selected graphics equal in width.

Same Height- This button will make the selected graphics equal in height.

Same Size- This button will resize selected graphics to be equal in width and height.

Space Across- This button will evenly space the selected graphics horizontally.

Space Down- This button will evenly space the selected graphics vertically.

CONTROL PANEL

LAYER- In the Layer tab you can change the properties of various layers. “Prior” sets the order of each layer,

“Process” turns each layer on and off, and “Visible” hides and shows each layer. Under “Work Parameter'' you can

set the max/min power of a layer as well as the speed. At the bottom of the layer tab there is a “Two-channel

power equal” button that makes the power setting for each laser tube equal. Clicking the “Advanced'' button will

bring up the following dialogue.



In this tab you can set laser on/off delay as well as change the power settings between each laser tube.

PROCESS

In this tab you can set a file to be repeated a specified number of times as well as enable the rotary function.



TEST

In this tab you are able to jog the laser manually and read the current position of the laser. You can change

the move mode between continuous (Machine moves as long as you are pressing the button) and dot move

(Machine moves for a specified distance).

DOCUMENTS

In this tab you can read the documents saved onto the onboard memory of the machine and perform

those jobs as well as calculate the time to run each job file.



INFO

In this tab you can see run time statistics for the machine.

Accumulated Open time: Total time the laser machine has been on

Accumulated Process time: Total time the laser has been running jobs

Previous process time: Total time to run the last job file that was ran

Accumulated Light time: Total time the laser has been firing

Accumulated process num: Total number of job files ran

X accumulated route(m): Total distance the X axis has covered

Y accumulated route(m): Total distance the Y axis has covered

Mainboard version: Software version of the laser machine controller

PROCESS PANEL

In this panel you can find various functions to be used when running the machine.



Positioning mode: You can select between Current point, Anchor point, and Mechanical origin. Current point will

start a job with the origin corresponding to wherever the laser head currently resides. Anchor point will start a job

with the origin corresponding to wherever the origin was set on the machine’s touch panel. Mechanical origin will

start a job with the origin corresponding to the top right corner of the bed.

Start: This button will start the job.

Suspend: This button will pause the job.

Stop: This button will stop and cancel the job.

File Save: This button will save the current workspace as a .oud file which the machine reads, can be used to

transfer files via flash drive.

File Out:

File Load: Transfers the current job directly to the laser machine.

Go Scale: Will draw a perimeter box around the job file with a speed set in the speed box.

Go Cut: Will draw a perimeter box around the job file while firing laser with the speed and power settings set in the

speed and power boxes.

USB Port: This button allows you to setup a specific USB port to be used or operate the machine over network via

ethernet.

TOUCH PANEL

Reset - Restarts the laser (Machine will re-home and return to origin)

Pulse - Pulses the laser for a set duration of time or for as long as the button is pressed depending on the machine

settings

Speed - This sets the max jogging speed of the system

Min/Max-Power - This sets the minimum and maximum power of the laser when not running a job file

File - This brings you to a screen to select/load job files

Start/Pause - This will start or pause a job file

Origin - This will set the origin for your job file

Frame - The laser will scan the perimeter of the selected job file

Esc - This functions as a back button as well as escaping from dialog Boxes

Enter - This is used to select options



Directional Arrows - These are used to jog the machine and scroll through options on the screen

Z/U - This is also used to scroll through options on the screen as well as operate the Z or U axis

Laser Button - This turns on the laser power supplies

Power Knobs - This adjusts the power delivered to the laser tube, thus affecting the output power of the laser.

Z move: This allows the user to move the Z table. Use the right arrow key to raise the table and the left arrow key to

lower the table.

U move: This allows the user to move the optimization line. Toggle between continuous and step movement with a

set step distance

Keyboard lock+:

Cur file entity+:

Laser Set+: This allows the user to toggle between continuous pulse and constant pulse with a set pulse duration

Origin set+: This allows the user to change the origin position for job files

Set factory para:

Set default para:

Auto focus: This button auto focuses to material in the machine if the autofocus option is installed

Language+: The language for the touch panel can be set here

IP config+: The IP address of the laser machine can be set with this function

Diagnoses: This displays all current alarms

Screen origin+: This allows the user to change origin position of the touch panel screen

Axes Reset+: This allows the user to reset one axis at a time

Extend setup+:



OPERATIONS

Vector Cutting
Vector cutting is the most common feature of a laser cutter. Vector cutting with a laser means “to cut a

line or shape”. When vector cutting, the laser follows the “vector lines” embedding in the vector image to cut out

the design. The laser starts at a designated location and follows the vector lines until the shape is cut out. This

process is highly accurate and requires no resolution adjustments because of the properties of a vector image.

Vector Images
In Vector Cut mode, the software receives information from the vector file and interprets it as a series of

paths for the laser head to follow. For the file to have vector information, the file must be a vector image. Vector

images are more flexible than raster images. These images are created using mathematical equations rather than

pixel blocks. Common vector file types include .dxf and .ai. These are easy to resize without losing resolution.

Company logos and branded graphics are usually vector images.

Raster Engraving
Raster engraving is the process by which complex designs are etched into a workpiece. Engraving can

range from a simple surface mark all the way through deep material removal. The most common type of engraving

is known as “Raster Engraving” or “Rastering”. For raster engraving, a laser has two states: on and off. Every black

pixel or “laser dot” is the result of the laser turning on and firing once at a location. This location is controlled by

the input image, which can be thought of as a “map” of on and off pixels. The laser fires individual pulses

corresponding to pixels in an image. When the laser is operating in raster mode the head moves rapidly from left to

right and slowly from top to bottom, engraving your image pixel by pixel and line by line.

Raster Images
Raster images use multiple colored pixels to form an image. JPEGs, BMPs and PNGs are common raster

image types. Most of the photos found on the Internet and photo prints are raster images. Raster images are

created using a fixed number of colored pixels, so they can’t be dramatically resized without distorting their

resolution. When sized to fit a space they weren’t designed to, the pixels become visibly grainy and the image

becomes distorted. When this happens, altered photos may appear pixelated or low resolution compared to the

original source. Because of this, it is important that you save raster files at precisely the dimensions needed to

eliminate possible resolution issues.

Direct Printing
The easiest way to import any file type to SmartCarve4.3 is to print it directly into the workspace window.

If there are ever any problems importing files in this manner, manually importing the file is the best manner. Most

design software have a simple method for directly printing to the SmartCarve software.

Design Software
To get the most from your laser, you will create designs using design software and transfer the files to the

laser for cutting. Full Spectrum Laser carries out unit testing using CorelDraw X7 and recommends that operators

use this program. If you use different design software and run into a problem with the print interface, we

recommend saving the file as a .dxf of .bmp. Limited testing has been carried out with CorelDraw X6 and it appears



to be a good choice, as well. Other popular packages include Adobe Illustrator, Inkscape and Google’s free online

vector drawing application. Additionally, most CAD packages are able to output drawings in a vector format for

printing; Autodesk 123D is particularly interesting for its cost (free) and built-in 3D slicing capabilities.

Positioning the Laser Head (Jog)
Operators will want to become accustomed to moving the laser head, in order to position the laser.

Jogging is when the operator uses the touch screen “jog” buttons, or the software “jog” buttons to move the laser

head. You can use the directional arrows to move the laser head to any position in the workspace. Pressing the

“Origin” button the the touch panel will set the origin for the file you are going to cut. With the default settings,

this corresponds to the lower left corner of your job file.

Project Workflow
Use this Project Workflow List for the “best practice” sequence for any project and follow the step-by-step

instructions from start to finish.

1. Create Design- Typically, projects are created in design software and then imported to SmartCarve. Generally, a

.dxf (R14 version) file is optimal for most vector cuts, as most design software has “export as .dxf” as a standard

feature. For rastering (engraving), a .jpeg file is best as these are bitmap files perfect for pixel based images. It is

important to know, at this stage, if you intend to do a vector cut or a raster and choose the most appropriate file

type (.dxf or .jpeg). This will greatly aid the software to run the job smoothly and quickly. Just about any design

software will work (You can choose the software you are most comfortable with, as long as you can convert files to

.dxf (which most can). You can also “direct print” to the software. Each operating system does this in a slightly

different way, so check the instructions for your particular computer.

2. Open Software- Briefly, you will turn on your computer and your Dual Head laser cutter and wait for both to

finish their boot cycle.

3. Import Design- Import your designs by selecting “File > Open”, or by clicking the “Bitmap File” or “Vector File”

button. This software detects a wide variety of file types, however, for vector cuts .dxf files work best and are

simple to convert on most design software. For raster engraving, the .JPEG file format is widely used and can easily

be taken from a cell phone photo or an image found online. It is important to know what files work best with

vector or raster images. A raster image is a pixel based image (bitmap) and works well as a .JPEG file. When you

import a .JPEG file, the software will automatically detect it as a raster file and will set up the project accordingly by

presenting raster options in the layer tab menu.

4. Adjust File Settings- It is again important to know if you intend to raster, vector cut or both. Once the file is

imported, and the image is clicked with your mouse, you will have access to the Layer Tab. Click this tab and select

the layer for your cuts and/or engravings. You can set the speed and power settings, as well as an individual power

setting for each laser tube.

5. Import Job to Laser- Now that your file is ready for processing, you must load it onto the laser. This can be done

by pressing the “File Out” button or by using the “File Save” button to save the file to a flash drive. Files saved onto

a flashdrive will be a .oud file type and can be loaded directly onto the machine using the USB port on the right

hand side. Alternatively, a job can be ran from the software by pressing the “Start” button but you must first

complete all of the following steps



6. Place Material- At this stage you will place your material into the laser bed workspace. The material can be

placed anywhere within the work bed, however, we recommend placing material close to the center of the work

bed. Once the material is placed, close the lid. Your material is what you will be cutting or engraving. Typical

materials include wood, acrylic, cardboard, fabric, etc. Note that it is the user’s responsibility to know the

components of any material used and the limitations of utilizing that material. (thickness, chemical residues, etc.)

Always check with the material manufacturer if there are any questions about its usage. We recommend using a

Materials Log to keep track of the different materials you use.

7. Focus- You will place a focusing ruler on top of the material you wish to cut. Then loosen the laser head thumb

screw to focus the laser head to the 6.0mm mark on the focus ruler. Generally a focus of 6.0mm works best, but as

the material thickness increases, you may find that cut speed and quality will increase if the focus distance is

reduced. Finally, retighten the focus head and remove the focus ruler from the workspace.

8. Align Laser to Material- Alignment of the material ensures the design to be cut is contained within the material

in the workspace. This process also makes sure the design is aligned to the material so the cut is positioned

straight. Typically this can be done with a simple vision check while jogging the perimeter. Follow these

instructions: By using the directional arrows on the touchscreen or in the software, move the laser dot to the

bottom left corner of your material. When placing a raster image, leave at least ½” inch of space on the left and

right side. When creating raster engravings, you must compensate for the left and right overshooting of the laser

head. This will prevent the head from crashing and prevent damage to your machine. Once the material looks

aligned, press the “Frame” button the touch panel or the “Go Scale” button on the software. The laser head will

automatically outline the material. You can then adjust the material as needed.

10. Turn On Accessories- Make sure all accessories are on and functioning. This includes the water chiller, air

pumps, and exhaust fan.

11. Start Your Job- You are now ready to run your job. Press the “Start” button on the touch panel or in the

software to start the job.

Adjusting Head Spacing
The left side cutting head on your laser, labeled “Laser 2”, is able to be spaced away from laser 1 in order

to fit your application. This process is easy to accomplish and is outlined in the steps below.

1. Loosen the brass thumb screw that clamps the X-gantry belt to laser 2

2. Adjust the head spacing to fit your desired design. For more precise positioning put a piece of material

under the laser heads and use the “Pulse” button on the touch panel to make a test fire onto the material,

measuring the distance between the two test fires.

3. Tighten the brass thumb screw.

4. Now jog the laser to the left until it makes a sudden stop. There should be an error on the screen notifying

you that you have reached the X-axis limit.



5. With your computer connected to the laser and SmartCarve open, click on the “Tools” toolbar and then

click the “Machine Settings” option.

6. Once the Machine Parameter Setting page is open, select “Axis Parameters” and enter “ym9999” when it

prompts you for a password.

7. With the X axis select, click the “Read” button to read the controller settings directly from the machine.

8. Now look on the machine touch panel and note the position in the X axis. You will subtract at least 5 mm

from this value and enter that new number into the “Breadth” box in the axis parameters.

9. Once you have made this adjustment, click the “Write” button to save this setting onto the machine’s

controller. You are now done adjusting the head spacing on your dual head laser.


